Условная функция и логические выражения в электронных таблицах Microsoft Exel 97. (49316)

Посмотреть архив целиком

http://monax.ru/order/ - рефераты на заказ (более 800 авторов в 230 городах СНГ).

Министерство образования и науки Украины

Николаевская общеобразовательная школа № 3






Реферат




по информатике


на тему:


Условная функция и логические выражения в электронных таблицах

Microsoft Exel 97.




Подготовила

ученица 11-А класса

Воронова Елена


Проверила

Девяткова В.Н.





2002


Условная функция и логические выражения в электронных таблицах

Microsoft Exel 97.


Условная функция. Общий вид условной функции следующий:

ЕСЛИ(<условие>; <выражение1>; <выражение2>)


Условие — это логическое выражение, которое может принимать значение ИСТИНА или ЛОЖЬ. <выражение 1> и <выражение 2> могут быть числами, формулами или текстами.

Условная функция, записанная в ячейку таблицы, выполняется так: если условие истинно, то значение данной ячейки определит <выражение 1>, в противном случае — <выражение 2>.

Логические выражения. Логические выражения строятся с помощью операций отношения (<, >, <= (меньше или равно), >= (больше или рано), =, <>(не равно)) и логических операций (логическое И, логическое ИЛИ, логическое отрицание НЕ). Результатом вычисления логического выражения являются логические величины ИСТИНА или ЛОЖЬ.

Существуют особенности записи логических операций в табличных процессорах: сначала записывается имя логической операции (И, ИЛИ, НЕ), а затем в круглых скобках перечисляются логические операнды.


И (логическое_значение1; Возвращает значение ИСТИНА, если все аргументы

Логическое_значение2; …) имеют значение ИСТИНА; возвращает значение

(AND) ЛОЖЬ, если хотя бы один аргумент имеет значение ЛОЖЬ; например, И(2+2=4; 2+3=5) равняется ИСТИНА, если ячейка B4 содержит число между 1 и 100, то И(1<B4; B4<100) равняется ИСТИНА


ИЛИ(логическое_значение1; Возвращает значение ИСТИНА, если хотя бы один

Логическое_значение2; …) аргументов имеет значение ИСТИНА и возвращает

(OR) значение ЛОЖЬ, если все аргументы имеют значение ЛОЖЬ; например, ИЛИ(2+2=4; 2+3=6) возвращает ИСТИНА; если ячейка B4 содержит число меньше 1 или больше 100, то ИЛИ(1<B4; B4>100) возвращает ИСТИНА.


НЕ (логическое_зачение) (NOT) Меняет на противоположное логическоезначение своего аргумента; например НЕ(2+2=5) возвращает ИСТИНА; если ячейка B4 содержит число меньше 1 или больше 100, то НЕ(ИЛИ(1<B4; B4>100)) возвращает ЛОЖЬ


Вложенные логические функции ЕСЛИ.

Формат записи:

=ЕСЛИ(усл.1; выражение В; ЕСЛИ(усл.2; выражение С; ЕСЛИ(…))).

Число вложенных функций в принципе может быть любое, но общая длина строки не должна быть слишком большой.

Пример 1. Найти работников, у которых имеются одновременно задолжен-ности по обоим видам кредита, и удержать от начисленной им суммы 20% в счет погашения кредитов. С остальных работников, имеющих задолженность по какому-либо одному виду кредита, удержать 10% от начисленной им суммы. Работникам, не имеющим задолженности по кредиту, проставить в графе “Удержано”- Б/К. В нашем примере логическая функция будет иметь следующий вид:

=ЕСЛИ(И(С3>0;D3>0);B3*0,2;ЕСЛИ(И(С3=0;D3=0);”б/к”;B3*0,1))


Данная логическая функция означает, что если одновременно задолженности по потребительскому кредиту на жилищное строительство больше нуля, то необходимо удержать 20% с начисленной суммы, если обе задолженности одновременно равны нулю, то необходимо вывести “б/к”, в противном случае необходимо удержать 10% от начисленной суммы.


Пример 2. Разработать таблицу, содержащую следующие сведения об абитуриентах: фамилия, оценки за экзамены по математике, русскому и иностранному языкам, сумма баллов за три экзамена и информацию о зачислении: если сумма баллов больше или равна проходному баллу и оценка за экзамен по математике — 4 или 5, то абитуриент зачислен в учебное заведение, в противном случае — нет.

Решение. Исходной информацией являются фамилии, оценки за экзамены и проходной балл. Сумма баллов и информация о зачислении вычисляются с помощью формул.

Первоначально следует подготовить таблицу в следующем виде:



А

В

С

D

Е

F

1

Проходной

балл:

13




2

Фамилия

Математика

Русский

Иностранный

Сумма

Зачислен

3








В ячейке С1 будет храниться значение проходного балла — 13. Формула в ячейке ЕЗ вычисляет сумму баллов за три экзамена: ВЗ + СЗ + D3. Формула в ячейке F3 задается с помощью условной функции: ЕСЛИ(И(ЕЗ>=$С$1;ВЗ>3);”ДА”;”НЕТ”)

Условие, записанное с помощью логической операции И, можно расшифровать так: сумма баллов (ЕЗ) >= проходному баллу (С1). И оценка за экзамен по математике (ВЗ) > 3. Если условие выполняется, то в клетке F3 будет отображаться текст — ДА, в противном случае — НЕТ.

Для проходного балла в формуле используется абсолютный адрес $С$1, так как проходной балл является одинаковым и неизменным для всех абитуриентов. После заполнения 3-ей строки формулами, можно произвести копирование соответствующих формул в нижние строки. Формулы в столбцах Е и F после копирования будут выглядеть так:



D

Е

F

1



2

Сумма

Зачислен

3

B3+C3+D3

ЕСЛИ(И(ЕЗ>=$С$1,ВЗ>3),“ДА”;“НЕТ”)

4

B4+C4+D4

ЕСЛИ(И(Е4>=$С$1,В4>3);“ДА”;“НЕТ”)

5

B5+C5+D5

ЕСЛИ(И(Е5>=$С$1,В5>3),“ДА”;“НЕТ”)



После ввода исходных данных получим таблицу в режиме отражения значений:



А

В

С

D

Е

F

1

Проходной

балл:

13




2

Фамилия

Математика

Русский

Иностранный

Сумма

Зачисление

3

Антонов

4

5

5

14

ДА

4

Воробьев

3

5

5

13

НЕТ

5

Синичкин

5

5

3

13

ДА

6

Воронина

5

4

3

12

НЕТ

7

Снегирев

3

5

4

12

НЕТ

8

Соколова

5

5

5

15

ДА



Случайные файлы

Файл
151582.rtf
182639.rtf
79476.rtf
22408-1.rtf
Milet.doc